import Foundation
let pattern = #"(?<=\d)(?=(\d{3})+(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
30000
30000000
546789101
3000.11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)