re = /(?<=\d)(?=(\d{3})+(?!\d))/
str = '30000
30000000
546789101
3000.11'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result