$re = '/(?<=\d)(?=(\d{3})+(?!\d))/';
$str = '30000
30000000
546789101
3000.11';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;