using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=(\d{3})+(?!\d))";
string substitution = @",";
string input = @"30000
30000000
546789101
3000.11";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}