# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=(\d{3})+(?!\d))/,/g;t' <<< "30000
30000000
546789101
3000.11"