use strict;
my $str = '30000
30000000
546789101
3000.11';
my $regex = qr/(?<=\d)(?=(\d{3})+(?!\d))/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";