#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\d)(?=(\d{3})+(?!\d))"
Local $sString = "30000" & @CRLF & _
"30000000" & @CRLF & _
"546789101" & @CRLF & _
"3000.11"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)