import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d)(?=(\\d{3})+(?!\\d))";
final String string = "30000\n"
+ "30000000\n"
+ "546789101\n"
+ "3000.11";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}