const regex = /(?<=\d)(?=(\d{3})+(?!\d))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)(?=(\\d{3})+(?!\\d))', 'g')
const str = `30000
30000000
546789101
3000.11`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);