import Foundation
let pattern = #"<a (.*)href="([^"]*)"(.*)>(.*)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="https://google.com">Google</a>
<a target=_blank href="https://google.com">Google</a>
<a href="https://google.com" class=link>Google</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[url=$2]$4[/url]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)