const regex = /<a (.*)href="([^"]*)"(.*)>(.*)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a (.*)href="([^"]*)"(.*)>(.*)<\\\/a>', 'gm')
const str = `<a href="https://google.com">Google</a>
<a target=_blank href="https://google.com">Google</a>
<a href="https://google.com" class=link>Google</a>
`;
const subst = `[url=$2]$4[/url]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);