# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a (.*)href="([^"]*)"(.*)>(.*)<\\/a>/[url=$2]$4[\/url]/gm;t' <<< "<a href=\"https://google.com\">Google</a>
<a target=_blank href=\"https://google.com\">Google</a>
<a href=\"https://google.com\" class=link>Google</a>
"