// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a (.*)href="([^"]*)"(.*)>(.*)<\/a>"#).unwrap();
let string = "<a href=\"https://google.com\">Google</a>
<a target=_blank href=\"https://google.com\">Google</a>
<a href=\"https://google.com\" class=link>Google</a>
";
let substitution = "[url=$2]$4[/url]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}