using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a (.*)href=""([^""]*)""(.*)>(.*)<\/a>";
string substitution = @"[url=$2]$4[/url]";
string input = @"<a href=""https://google.com"">Google</a>
<a target=_blank href=""https://google.com"">Google</a>
<a href=""https://google.com"" class=link>Google</a>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}