$re = '/<a (.*)href="([^"]*)"(.*)>(.*)<\/a>/m';
$str = '<a href="https://google.com">Google</a>
<a target=_blank href="https://google.com">Google</a>
<a href="https://google.com" class=link>Google</a>
';
$subst = "[url=$2]$4[/url]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;