#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a (.*)href="([^"]*)"(.*)>(.*)<\/a>"
Local $sString = "<a href="https://google.com">Google</a>" & @CRLF & _
"<a target=_blank href="https://google.com">Google</a>" & @CRLF & _
"<a href="https://google.com" class=link>Google</a>" & @CRLF & _
""
Local $sSubst = "[url=$2]$4[/url]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)