use strict;
my $str = '<a href="https://google.com">Google</a>
<a target=_blank href="https://google.com">Google</a>
<a href="https://google.com" class=link>Google</a>
';
my $regex = qr/<a (.*)href="([^"]*)"(.*)>(.*)<\/a>/mp;
my $subst = '[url=$2]$4[/url]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";