package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a (.*)href="([^"]*)"(.*)>(.*)<\/a>`)
var str = `<a href="https://google.com">Google</a>
<a target=_blank href="https://google.com">Google</a>
<a href="https://google.com" class=link>Google</a>
`
var substitution = "[url=$2]$4[/url]"
fmt.Println(re.ReplaceAllString(str, substitution))
}