import Foundation
let pattern = #"(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
title case split
world's title
fish&chips
(capitalize)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1[$2]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)