import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s+[^a-z0-9]+|[^a-z0-9']+\\s+|[\\s&\\/]|^)+(\\w)";
final String string = "title case split\n"
+ "world's title\n\n"
+ "fish&chips\n"
+ "(capitalize)";
final String subst = "$1[$2]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}