// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)").unwrap();
let string = "title case split
world's title
fish&chips
(capitalize)";
let substitution = "$1[$2]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}