use strict;
my $str = 'title case split
world\'s title
fish&chips
(capitalize)';
my $regex = qr/(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)/p;
my $subst = '$1[$2]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";