$re = '/(\s+[^a-z0-9]+|[^a-z0-9\']+\s+|[\s&\/]|^)+(\w)/';
$str = 'title case split
world\'s title
fish&chips
(capitalize)';
$subst = "$1[$2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;