using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)";
string substitution = @"$1[$2]";
string input = @"title case split
world's title
fish&chips
(capitalize)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}