package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)`)
var str = `title case split
world's title
fish&chips
(capitalize)`
var substitution = "$1[$2]"
fmt.Println(re.ReplaceAllString(str, substitution))
}