# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\\/]|^)+(\w)/$1[$2]/g;t' <<< "title case split
world's title
fish&chips
(capitalize)"