import Foundation
let pattern = #"\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
604 685 3361 ext. 106
250 - 590 - 6573
2505906573
2505906573
1 250 729 8225
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}