# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)"
test_str = ("604 685 3361 ext. 106\n"
"250 - 590 - 6573\n"
"2505906573\n"
" 2505906573\n"
"1 250 729 8225")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.