// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)").unwrap();
let string = "604 685 3361 ext. 106
250 - 590 - 6573
2505906573
2505906573
1 250 729 8225";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}