package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)`)
var str = `604 685 3361 ext. 106
250 - 590 - 6573
2505906573
2505906573
1 250 729 8225`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}