use strict;
my $str = '604 685 3361 ext. 106
250 - 590 - 6573
2505906573
2505906573
1 250 729 8225';
my $regex = qr/\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}