import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\D*?(\\d{3})\\D*?(\\d{3})\\D*?(\\d{4})\\s?(.*)";
final String string = "604 685 3361 ext. 106\n"
+ "250 - 590 - 6573\n"
+ "2505906573\n"
+ " 2505906573\n"
+ "1 250 729 8225";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}