#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)"
Local $sString = "604 685 3361 ext. 106" & @CRLF & _
"250 - 590 - 6573" & @CRLF & _
"2505906573" & @CRLF & _
" 2505906573" & @CRLF & _
"1 250 729 8225"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")