$re = '/\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)/m';
$str = '604 685 3361 ext. 106
250 - 590 - 6573
2505906573
2505906573
1 250 729 8225';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);