using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D*?(\d{3})\D*?(\d{3})\D*?(\d{4})\s?(.*)";
string input = @"604 685 3361 ext. 106
250 - 590 - 6573
2505906573
2505906573
1 250 729 8225";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}