import Foundation
let pattern = #"\\(\w)*\\"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
D:\pcap\WebMail
D:\pcap1\WebMail\1\1
C:\pcap\WebMail\sd\
D:\pcapFixed\WebMail\AOL\AOL_Accessible\20121107\AOL_lite_ACCESSIBLE_001_Login.xml
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\replacedFolder\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)