use strict;
my $str = 'D:\\pcap\\WebMail
D:\\pcap1\\WebMail\\1\\1
C:\\pcap\\WebMail\\sd\\
D:\\pcapFixed\\WebMail\\AOL\\AOL_Accessible\\20121107\\AOL_lite_ACCESSIBLE_001_Login.xml';
my $regex = qr/\\(\w)*\\/mp;
my $subst = '\\\\replacedFolder\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";