// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\(\w)*\\").unwrap();
let string = "D:\\pcap\\WebMail
D:\\pcap1\\WebMail\\1\\1
C:\\pcap\\WebMail\\sd\\
D:\\pcapFixed\\WebMail\\AOL\\AOL_Accessible\\20121107\\AOL_lite_ACCESSIBLE_001_Login.xml";
let substitution = "\\\\replacedFolder\\\\";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}