const regex = /\\(\w)*\\/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\(\\w)*\\\\', 'mg')
const str = `D:\\pcap\\WebMail
D:\\pcap1\\WebMail\\1\\1
C:\\pcap\\WebMail\\sd\\
D:\\pcapFixed\\WebMail\\AOL\\AOL_Accessible\\20121107\\AOL_lite_ACCESSIBLE_001_Login.xml`;
const subst = `\\replacedFolder\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);