package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\(\w)*\\`)
var str = `D:\pcap\WebMail
D:\pcap1\WebMail\1\1
C:\pcap\WebMail\sd\
D:\pcapFixed\WebMail\AOL\AOL_Accessible\20121107\AOL_lite_ACCESSIBLE_001_Login.xml`
var substitution = "\\replacedFolder\\"
fmt.Println(re.ReplaceAllString(str, substitution))
}