# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\\(\w)*\\"
test_str = ("D:\\pcap\\WebMail\n"
"D:\\pcap1\\WebMail\\1\\1\n"
"C:\\pcap\\WebMail\\sd\\\n"
"D:\\pcapFixed\\WebMail\\AOL\\AOL_Accessible\\20121107\\AOL_lite_ACCESSIBLE_001_Login.xml")
subst = "\\\\replacedFolder\\\\"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.