using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(\w)*\\";
string substitution = @"\\replacedFolder\\";
string input = @"D:\pcap\WebMail
D:\pcap1\WebMail\1\1
C:\pcap\WebMail\sd\
D:\pcapFixed\WebMail\AOL\AOL_Accessible\20121107\AOL_lite_ACCESSIBLE_001_Login.xml";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}