# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\(\w)*\\/\\replacedFolder\\/mg;t' <<< "D:\pcap\WebMail
D:\pcap1\WebMail\1\1
C:\pcap\WebMail\sd\
D:\pcapFixed\WebMail\AOL\AOL_Accessible\20121107\AOL_lite_ACCESSIBLE_001_Login.xml"