// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)=").unwrap();
let string = "\"a:link\": \"<a href=\\\"http://|\\\">\",
\"a:mail\": \"<a href=\\\"mailto:|\\\">\",
\"abbr\": \"<abbr title=\\\"\\\">\",
\"acr|acronym\": \"<acronym title=\\\"\\\">\",
\"base\": \"<base href=\\\"\\\" />\",
\"basefont\": \"<basefont/>\",
\"br\": \"<br/>\",
\"frame\": \"<frame/>\",
\"hr\": \"<hr/>\",
\"bdo\": \"<bdo dir=\\\"\\\">\",
\"bdo:r\": \"<bdo dir=\\\"rtl\\\">\",
\"bdo:l\": \"<bdo dir=\\\"ltr\\\">\",
\"col\": \"<col/>\",
\"link\": \"<link rel=\\\"stylesheet\\\" href=\\\"\\\" />\"";
let substitution = "what => ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}