use strict;
my $str = '"a:link": "<a href=\\"http://|\\">",
"a:mail": "<a href=\\"mailto:|\\">",
"abbr": "<abbr title=\\"\\">",
"acr|acronym": "<acronym title=\\"\\">",
"base": "<base href=\\"\\" />",
"basefont": "<basefont/>",
"br": "<br/>",
"frame": "<frame/>",
"hr": "<hr/>",
"bdo": "<bdo dir=\\"\\">",
"bdo:r": "<bdo dir=\\"rtl\\">",
"bdo:l": "<bdo dir=\\"ltr\\">",
"col": "<col/>",
"link": "<link rel=\\"stylesheet\\" href=\\"\\" />"';
my $regex = qr/(\w+)=/p;
my $subst = 'what => ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";