const regex = /(\w+)=/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)=', 'g')
const str = `"a:link": "<a href=\\"http://|\\">",
"a:mail": "<a href=\\"mailto:|\\">",
"abbr": "<abbr title=\\"\\">",
"acr|acronym": "<acronym title=\\"\\">",
"base": "<base href=\\"\\" />",
"basefont": "<basefont/>",
"br": "<br/>",
"frame": "<frame/>",
"hr": "<hr/>",
"bdo": "<bdo dir=\\"\\">",
"bdo:r": "<bdo dir=\\"rtl\\">",
"bdo:l": "<bdo dir=\\"ltr\\">",
"col": "<col/>",
"link": "<link rel=\\"stylesheet\\" href=\\"\\" />"`;
const subst = `what => `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);