# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)="
test_str = ("\"a:link\": \"<a href=\\\"http://|\\\">\",\n"
"\"a:mail\": \"<a href=\\\"mailto:|\\\">\",\n"
"\"abbr\": \"<abbr title=\\\"\\\">\",\n"
"\"acr|acronym\": \"<acronym title=\\\"\\\">\",\n"
"\"base\": \"<base href=\\\"\\\" />\",\n"
"\"basefont\": \"<basefont/>\",\n"
"\"br\": \"<br/>\",\n"
"\"frame\": \"<frame/>\",\n"
"\"hr\": \"<hr/>\",\n"
"\"bdo\": \"<bdo dir=\\\"\\\">\",\n"
"\"bdo:r\": \"<bdo dir=\\\"rtl\\\">\",\n"
"\"bdo:l\": \"<bdo dir=\\\"ltr\\\">\",\n"
"\"col\": \"<col/>\",\n"
"\"link\": \"<link rel=\\\"stylesheet\\\" href=\\\"\\\" />\"")
subst = "what => "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.