import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)=";
final String string = "\"a:link\": \"<a href=\\\"http://|\\\">\",\n"
+ "\"a:mail\": \"<a href=\\\"mailto:|\\\">\",\n"
+ "\"abbr\": \"<abbr title=\\\"\\\">\",\n"
+ "\"acr|acronym\": \"<acronym title=\\\"\\\">\",\n"
+ "\"base\": \"<base href=\\\"\\\" />\",\n"
+ "\"basefont\": \"<basefont/>\",\n"
+ "\"br\": \"<br/>\",\n"
+ "\"frame\": \"<frame/>\",\n"
+ "\"hr\": \"<hr/>\",\n"
+ "\"bdo\": \"<bdo dir=\\\"\\\">\",\n"
+ "\"bdo:r\": \"<bdo dir=\\\"rtl\\\">\",\n"
+ "\"bdo:l\": \"<bdo dir=\\\"ltr\\\">\",\n"
+ "\"col\": \"<col/>\",\n"
+ "\"link\": \"<link rel=\\\"stylesheet\\\" href=\\\"\\\" />\"";
final String subst = "what => ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}