using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)=";
string substitution = @"what => ";
string input = @"""a:link"": ""<a href=\""http://|\"">"",
""a:mail"": ""<a href=\""mailto:|\"">"",
""abbr"": ""<abbr title=\""\"">"",
""acr|acronym"": ""<acronym title=\""\"">"",
""base"": ""<base href=\""\"" />"",
""basefont"": ""<basefont/>"",
""br"": ""<br/>"",
""frame"": ""<frame/>"",
""hr"": ""<hr/>"",
""bdo"": ""<bdo dir=\""\"">"",
""bdo:r"": ""<bdo dir=\""rtl\"">"",
""bdo:l"": ""<bdo dir=\""ltr\"">"",
""col"": ""<col/>"",
""link"": ""<link rel=\""stylesheet\"" href=\""\"" />""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}