import Foundation
let pattern = #".*(https)*\/(.*)\.(.*\?|.*$)(.*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2.$3 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)